New site glitch report

Instead of emailing or messaging the Admins or Mods with technical support questions or comments about the site, we prefer you check here to see if someone else has had the same difficulty or has made the same suggestion. What you're after might have already been posted and addressed here or within the FAQ. If not, please post a detailed description of the problem/suggestion and someone from the HST team will address your needs shortly. If you can't login/post and are unable to reset your password on your own, you may contact us directly.
Post Reply
User avatar
Jimr
Forums Moderator
Forums Moderator
Posts: 1961
Joined: Fri Jul 31, 2009 2:14 pm
Experience: Level 4 Explorer
Location: Redondo Beach

Re: New site glitch report

Post by Jimr » Tue Mar 10, 2015 9:08 am

One interesting thing I'm seeing while waiting for pages to load is in the feedback from the browser
"Waiting for www.highsierratopix.com"
"Waiting for highsierratopix.com"

It shows the first line, then the second line on (I assume) every wait state. I don't know if this is correct or redundancy.


“Posterity! You will never know, how much it cost the present generation, to preserve your Freedom! I hope you will make a good use of it. If you do not, I shall repent in Heaven, that I ever took half the pains to preserve it.”

-John Adams






User avatar
fishmonger
Topix Fanatic
Posts: 1202
Joined: Fri Jun 13, 2008 10:27 am
Experience: Level 4 Explorer
Location: Madison, WI
Contact:

Re: New site glitch report

Post by fishmonger » Tue Mar 10, 2015 2:37 pm

response time getting progressively worse. 15-20 seconds for any page to load today. Was about 10 sec yesterday. Seems to be database related, as the background and header loads immediately, but anything that requires a query stalls

User avatar
ERIC
Your Humble Host & Forums Administrator
Your Humble Host & Forums Administrator
Posts: 3229
Joined: Fri Oct 28, 2005 9:13 am
Experience: Level 4 Explorer
Location: between the 916 and 661

Re: New site glitch report

Post by ERIC » Wed Mar 11, 2015 9:53 am

Sorry for not checking in sooner. It's been a really busy week at work and back home dealing with a 3.5 year old sick kid and an 18 month old with a broken collar bone.

Status of the slowness issue is that copeg and I think we have identified at least one source of the major problems if not the primary or only source. We don't think it's database related, rather there are a bunch of extra hooks in the code calling js files that either do not exist or are not necessary. We're working now to correct the issue and we really do appreciate everyone's wonderful patience while we attempt to juggle our personal lives with addressing bug fixes.

Cheers,
ERIC
New members, please consider giving us an intro!
Follow us on Twitter @HighSierraTopix. Use hashtags #SIERRAPHILE #GotSierra? #GotMountains?
Follow us on Facebook: https://www.facebook.com/HighSierraTopix

User avatar
Jimr
Forums Moderator
Forums Moderator
Posts: 1961
Joined: Fri Jul 31, 2009 2:14 pm
Experience: Level 4 Explorer
Location: Redondo Beach

Re: New site glitch report

Post by Jimr » Wed Mar 11, 2015 12:12 pm

Wait until they become teenagers LOL. Then, the fun really begins.
“Posterity! You will never know, how much it cost the present generation, to preserve your Freedom! I hope you will make a good use of it. If you do not, I shall repent in Heaven, that I ever took half the pains to preserve it.”

-John Adams

User avatar
BSquared
Founding Member
Posts: 910
Joined: Tue Nov 01, 2005 3:31 pm
Experience: Level 3 Backpacker
Location: Jericho, VT

Re: New site glitch report

Post by BSquared » Fri Mar 13, 2015 6:21 am

Jimr wrote:Wait until they become teenagers LOL. Then, the fun really begins.
...or when they move back in in their 20s :angry:

Required on-topic content: response time seems pretty good this morning, at least out here on the right coast.
—B²

User avatar
rlown
Topix Docent
Posts: 7600
Joined: Thu Oct 25, 2007 5:00 pm
Experience: Level 4 Explorer
Location: Wilton, CA

Re: New site glitch report

Post by rlown » Fri Mar 13, 2015 6:44 pm

ERIC wrote:Sorry for not checking in sooner. It's been a really busy week at work and back home dealing with a 3.5 year old sick kid and an 18 month old with a broken collar bone.

Status of the slowness issue is that copeg and I think we have identified at least one source of the major problems if not the primary or only source. We don't think it's database related, rather there are a bunch of extra hooks in the code calling js files that either do not exist or are not necessary. We're working now to correct the issue and we really do appreciate everyone's wonderful patience while we attempt to juggle our personal lives with addressing bug fixes.

Cheers,
ERIC
In Chrome, I'm running the Java console and watching the response time and failures. and i agree it's the js hooks. Not sure why CSS is throwing so much crap, but shouldn't that all be cached anyway even if you don't need it?

I love the java console. Firefox has a better one. I actually use it in my job to double check what our tool does for our corporate sites.

Still seeing 10-15 seconds on pages for the HST, which isn't bad, but not snappy. Keep up the good work, Eric and Greg!! It's much appreciated.

Russ

User avatar
ERIC
Your Humble Host & Forums Administrator
Your Humble Host & Forums Administrator
Posts: 3229
Joined: Fri Oct 28, 2005 9:13 am
Experience: Level 4 Explorer
Location: between the 916 and 661

Re: New site glitch report

Post by ERIC » Fri Mar 13, 2015 7:07 pm

I removed some of those bogus hooks and will remove a few more tomorrow as I work my way through them to be sure I'm not removing anything that's essential. It does seem to be getting a bit better.
New members, please consider giving us an intro!
Follow us on Twitter @HighSierraTopix. Use hashtags #SIERRAPHILE #GotSierra? #GotMountains?
Follow us on Facebook: https://www.facebook.com/HighSierraTopix

User avatar
ERIC
Your Humble Host & Forums Administrator
Your Humble Host & Forums Administrator
Posts: 3229
Joined: Fri Oct 28, 2005 9:13 am
Experience: Level 4 Explorer
Location: between the 916 and 661

Re: New site glitch report

Post by ERIC » Sat Mar 14, 2015 2:16 pm

Any better now (speed-wise)?
New members, please consider giving us an intro!
Follow us on Twitter @HighSierraTopix. Use hashtags #SIERRAPHILE #GotSierra? #GotMountains?
Follow us on Facebook: https://www.facebook.com/HighSierraTopix

User avatar
rlown
Topix Docent
Posts: 7600
Joined: Thu Oct 25, 2007 5:00 pm
Experience: Level 4 Explorer
Location: Wilton, CA

Re: New site glitch report

Post by rlown » Sat Mar 14, 2015 2:48 pm

ok.. now it's really snappy!! very nicely done. 7 seconds shaved off responses at least!

Russ

User avatar
ERIC
Your Humble Host & Forums Administrator
Your Humble Host & Forums Administrator
Posts: 3229
Joined: Fri Oct 28, 2005 9:13 am
Experience: Level 4 Explorer
Location: between the 916 and 661

Re: New site glitch report

Post by ERIC » Sat Mar 14, 2015 3:11 pm

Good. I paid these guys to do the work so I wouldn't have to, but now I find myself fixing their sloppy codding (with Greg's help).
New members, please consider giving us an intro!
Follow us on Twitter @HighSierraTopix. Use hashtags #SIERRAPHILE #GotSierra? #GotMountains?
Follow us on Facebook: https://www.facebook.com/HighSierraTopix

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest